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INTRODUCTION TO PYTHON
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Based on previous lecture by F. Galatolo

https://github.com/galatolofederico/python-very-informal-introduction/blob/master/slides.pdf


WHY PYTHON?
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• High level

• Open source

• Portable: write once run
everywhere

• Extendible in C/C++

• Easy to learn

• With a mature and supportive 
community

• With hundreds of thousands of 
libraries, packages and 
frameworks, supported by big 
players (Google, Facebook, 
Amazon) and non-profit 
organizations

Created by Guido van Rossum in the 1980s, to be a general-purpose

language with a simple and readable syntax. Today is more and more required

since it is:



VIRTUAL ENVIRONMENT
• In each project, a number of Python packages are imported and used. Each of
them may requires a given version of other packages and Python as well.

•A virtual environment is a self-contained directory tree that contains a Python
installation for a particular version of Python, plus a number of additional
packages

• In this way, the project-wide dependencies are stored, easily snapshotted and
retrieved

•Create a Virtual Environment with Python X.Y in folder env

virtualenv --python=pythonX.Y env

•Activate the Virtual Environment

source ./env/bin/activate

. ./env/bin/activate

•Deactivate the Virtual Environment

deactivate
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BASIC PACKAGES MANAGING

•Install package

pip install package

•Uninstall package

pip uninstall package

•Snapshot installed packages in requirements.txt

pip freeze > requirements.txt

•Install all packages snapshotted in requirements.txt

pip install -r requirements.txt

•Now you can import and use this packages in your project
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ANACONDA

Anaconda is a distribution of Python that aims to simplify package management
and deployment, suitable for Windows, Linux, and macOS.

Package versions in Anaconda are managed by conda, an open source, cross-
platform, language-agnostic package manager and environment management
system

Conda analyses the current environment including everything currently installed,
works out how to install/run/update a compatible set of dependencies
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PYTHON IDE + MINICONDA = PYCHARM
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Based on previous lecture by A. L. Alfeo

Pycharm offers configurable python interpreter

and virtual environment support. 

https://www.jetbrains.com/help/pycharm/configuring-local-python-interpreters.html
https://www.jetbrains.com/help/pycharm/creating-virtual-environment.html


INSTALLATION 1/2

1. Install PyCharm using this links:

 Linux

 Windows

 MacOs

2. During PyCharm installation 

enable “open folder as project”
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https://download.jetbrains.com/python/pycharm-community-anaconda-2020.2.3.tar.gz
https://download.jetbrains.com/python/pycharm-community-anaconda-2020.2.3.exe
https://download.jetbrains.com/python/pycharm-community-anaconda-2020.2.3.dmg


INSTALLATION  2/2

•Accept the JetBrains Privacy Policy

•Choose the UI theme you prefer

•Do not install any featured plugin

• Install Miniconda: includes the

conda environment manager,

Python, the packages they

depend on, and a small number of

other useful packages (e.g. pip).

•Remember, Miniconda can be

installed at any time from

Tools -> Install Miniconda3

•Start using PyCharm
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https://docs.conda.io/en/latest/miniconda.html
https://en.wikipedia.org/wiki/Python_(programming_language)


NEW PROJECT
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Create a new project. Name it “first_project”.

If needed set the conda executable path.



GUI
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Project view

Menu Toolbar

Editor

Run/Debug buttons

Console and Tool windows

https://www.jetbrains.com/help/pycharm/guided-tour-around-the-user-interface.html
https://www.jetbrains.com/help/pycharm/using-consoles.html#context


INTERPRETER: DEFAULT CONFIGURATIONS
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Now you can run it!

Is there a red X here?



PYTHON BASICS

13



INDENTATION

In python code blocks are not surrounded by curly brackets. Just use 
the correct indentation!
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BUILT-IN TYPES

Python is dynamically typed, i.e. types are determined at runtime.

Variables can freely change type during the execution.

In python there are a lot of built-in types, the most notables are:

•Boolean (bool)

•Strings (str)

•Numbers (int, float)

•Sequences (list, tuple)

•Mapping (dict)
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VARIABLES
Variables can be assigned to given values…

pi = 3

name = “Pippo"

…Even multiple variables at once via iterable unpacking. Click for more 
on iterable data structures (e.g. lists, tuples…)!

pi, name = 3, “Pippo"

first, second, third = SomeSequence

In Python everything is stored and passed as reference with the only 
exception of Numbers.

a = [1, 2, 3]

b = a

b[0] = 5 # now a = [5, 2, 3]
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https://docs.python.org/3/tutorial/datastructures.html


CONDITIONAL INSTRUCTION 1/2

Simple conditional instruction with the if keyword.

Python uses and and or as logical operators instead of && and ||

Inline conditional instructions can be used as it follows
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CONDITIONAL INSTRUCTION 2/2

The if-else statement is used as it follows

There is no switch case statement in Python. Just use if and elif
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TRY IT YOURSELF!
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LOOPS 1/2

There is no do-while loop, just while and for loops

Tuple unpacking can be used with loops iterations

20



LOOPS 2/2

zip() combines one-by-one the elements of two or more iterables

enumerate() returns a list of (index, element) tuples

For efficient loops an iterable object can leverage the itertools packages.

The simplest iterable can be a list created via list comprehension
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https://docs.python.org/3/library/itertools.html


FUNCTIONS: DEFINITION

A new function can be defined by using the keyword def

Default argument are indicated with =

Inline functions can be created by using the lambda keyword
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FUNCTIONS: POSITIONAL ARGUMENTS

A variable number of arguments can be defined via the * symbol

A sequence can be passed as positional arguments as it follows

23



FUNCTIONS: KEYWORD ARGUMENTS

A function using keyword arguments needs to have the ** symbol as 
last argument.

You can also pass a dict of keyword arguments using the symbol ** 
while calling the method
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TRY IT YOURSELF!
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def print_hi(**kwargs):
if kwargs["number"] > 0:

squares = [i**2 for i in range(0, kwargs["number"])]
for elem in squares:

print(elem)
elif kwargs["number"] == 0:

print("Just a zero?!")
else:

print("Hi, my name is " + kwargs["name"])

if __name__ == '__main__':
argv = dict(name="Luca", number=0)
print_hi(**argv)

Modify the print_hi function to accept a dict as an argument. Print:

• the first number squares, if number is greater than zero

• "Just a zero?!" if number is zero 

• «Hi, my name is name», otherwise



CLASSES: METHODS

In python classes are defined with the class keyword. Class methods
are defined with the def keyword. Class method have the first
argument equal to self, in contrast with static method.

However, unless you want to use a decorator, Python does not know
about static/non-static methods, it is all about notation!

26

https://www.python.org/dev/peps/pep-0318/


CLASSES: ATTRIBUTES

In python you can create, modify and retrieve instance attributes
using the dot (.) selector on the instance reference. You can create and
assign an instance attribute everywhere in a class method.

You can create class attributes specifying them after the class
declaration. You can modify and retrieve class attributes using the dot
(.) selector on the class reference
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CLASSES: VISIBILITY

In python there is no such thing as a private method or attribute.
Everything is public. The naming convention for “private” methods
and attributes is to precede their name with the _ symbol.
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CLASSES: CONSTRUCTOR

In python the construct function is named __init__ and it is called at
object instantiation.

You can specify one or more arguments. The first argument is the
object instance reference.
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CLASSES: INHERITANCE

You can extend a base class with another specifying the base class
between the parenthesis at class definition. In order to get the base
class reference you need to use the super() function.
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https://docs.python.org/3/tutorial/classes.html#inheritance
https://docs.python.org/3/library/functions.html#super


TRY IT YOURSELF!
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class Person:
def __init__(self, name, number):

self.name = name
self.number = number

def print_hi(self):
if self.number > 0:

squares = [i**2 for i in range(0, self.number)]
for elem in squares:

print(elem)
elif self.number == 0:

print("Just a zero?!")
else:

print("Hi, my name is " + self.name)

Include the modified version of print_hi in the class Person, use the class attributes, 

and derive the new class Student!

class Student(Person):
def print_hi(self):

print("I'm a student!")

if __name__ == '__main__':
p = Person("Luca", 0)
p.print_hi()
print(p.name)

s = Student("Luca",  -2)
s.print_hi()
print(s.name)



MORE ON CLASSES: DATA MODEL

The are a lot of built-in functions provided by the base class of all the
classes object. Each of which provide a specific behavior, a few are:

•__len__ (self)

Returns the “length” of the object (called by len())

•__str__ (self)

Returns the object as a string (called by str())

•__lt__ (self, other), __lt__ (self, other), __eq__ (self,other)

Called when the object is used in a comparison

•__getitem__ (self, key), __setitem__ (self, key, value)

Called in square brackets access
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WORKING WITH EXISTING PROJECTS
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Pycharm provides different functionalities for project and code

navigation.

Navigate the project with specialized project views, use shortcuts, jump

between files, classes, methods and usages.

You can create a Python project by opening a folder as a project or even

from scratch, by creating or importing the python files.

In this lecture we will not start from scratch…

https://www.jetbrains.com/help/pycharm/working-with-source-code.html
https://www.jetbrains.com/help/pycharm/mastering-keyboard-shortcuts.html
https://www.jetbrains.com/help/pycharm/creating-files-from-templates.html#creating-new-file-from-template


OPEN A PROJECT

1. Unzip “simpleClassifier.rar” 

2. Open the resulting folder “as a PyCharm 
project” 
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http://www.iet.unipi.it/m.cimino/lsse/pres/Alfeo,%20simpleClassifier.zip


ALTERNATIVE INTERPRETER CONFIGURATION
File > Settings > Project > Python interpreter > Show all 

> Conda Environment > New environment 

Location and conda executable may have slightly different paths (the first part) according 
to your miniconda3 location.

Apply > Ok
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https://www.jetbrains.com/help/pycharm/configuring-python-interpreter.html#add_new_project_interpreter


PROJECT REQUIREMENTS 1/2
The requirements are all the packages that our software needs to run properly. Those
can be installed with a PyCharm plugin.

Double click on “requirements.txt” in the Project View > Install Plugin

Once the plugin is installed click on “Install requirements”, select all and click install.
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• If everything goes smoothly you might see the package installation status progress
at the bottom of the GUI.

• Once the package installation is done a notification appears, but it is still NOT
possible to go to next step, at least until PyCharm has finished "Updating
skeletons".

• Each package can also be installed via GUI or with the Terminal by using

• “pip install <name_lib>” to install a single package

• “pip install –r requirements.txt” to install the packages on the requirements.txt

PROJECT REQUIREMENTS 2/2
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https://www.jetbrains.com/help/pycharm/installing-uninstalling-and-upgrading-packages.html
https://en.wikipedia.org/wiki/Pip_(package_manager)


CHECK THE PACKAGES AVAILABLE 

It can take some minutes to complete the requirements installation. A restart may be 
required before moving to the next step!

Once done you can see (add, eliminate and upgrade*) the packages and libraries 
available in your virtual environment by checking :

File > Settings > Project > Python Interpreter
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*



CONFIGURE THE FIRST RUN
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1. Click “Add configuration”

2. Select “Python”

3. Select “main.py” in your project folder.

4. Click OK



RUN IT!

40The confusion matrix!Txt with evaluation score!

Click RUN

https://en.wikipedia.org/wiki/Confusion_matrix
https://docs.python.org/3/tutorial/inputoutput.html#reading-and-writing-files


QUESTIONS?
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